Camtasia Studio Not Recording Menus

UPDATE 6/20/2012: I have confirmed that this same bug exists in Camtasia Studio 8.0.0 as well.

TechSmith is a great company that makes great products (www.techsmith.com).  Camtasia Studio and Snagit are two of their products that I use, and as I discovered today, their customer support staff is awesome as well.

While working on a video series for a client I discovered a rare bug in Camtasia Studio Version 7.1.1.  How do I know it is rare?  Because the TechSmith support guy, after talking to a Senior support guy, told me that it was.  🙂

After playing back the demo that I had recorded I discovered that any menus from the menu bar or context menus did not show up in the video.  I happened to be recording Visual Studio 2010, but from my understanding this is not specific to the program being recorded.  This will also leave intellisense out of your videos–for my fellow Visual Studio developers.

I could still see my mouse movements as if they were clicking on menus and submenus, but all you could see is the normal part of the program that would lie underneath those menus.

THE FIX (screenshot below):

  1. Open “Camtasia Recorder” (not Camtasia Studio)
  2. Go to Tools > Options
  3. On the “General” tab, Uncheck “Capture layered windows”
  4. Click OK
  5. Reopen Options
  6. Recheck “Capture layered windows”
  7. Click OK
  8. Problem solved

Like I said, this bug is quite rare according to the TechSmith folks.  So like me, you probably were having trouble finding any info on it if you are one of the lucky folks to come across this problem.  🙂  So, I hope this saves you some time.  Thanks for reading!

image

Advertisements